# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[A-Z]/B/g;t' <<< "\"R$ 2,010,000,020.00\""