const regex = /^[A-Z]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]', 'g')
const str = `"R\$ 2,010,000,020.00"`;
const subst = `B`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);