$re = '/^[A-Z]/';
$str = '"R$ 2,010,000,020.00"';
$subst = "B";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;