use strict;
my $str = '"R$ 2,010,000,020.00"';
my $regex = qr/^[A-Z]/p;
my $subst = 'B';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";