re = /RTL_433toMQTT\/([^\/:]+)\/?:.* /m
str = 'rtl433:home/rtl433/RTL_433toMQTT/Rubicson-Temperature/1/244:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Nexus-TH/1/9:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/WT450-TH/1/1:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Secplus-v1/0:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Interlogix-Security/motion/485865:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Generic-Motion:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/LaCrosse-TX141THBv2/0/168:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/0:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/128:.* { json2nameValue($EVENT) }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end