#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "-?\$+?(?:[A-Fa-f]*)?(?:\d)*"
Local $sString = "$0" & @CRLF & _
"$1" & @CRLF & _
"$D" & @CRLF & _
"$FFFF" & @CRLF & _
"$0A1B2C3D4E5F" & @CRLF & _
"$BadCafe" & @CRLF & _
"-$10" & @CRLF & _
"-$aBcDeF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")