import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-?\\$+?(?:[A-Fa-f]*)?(?:\\d)*";
final String string = "$0\n"
+ "$1\n"
+ "$D\n"
+ "$FFFF\n"
+ "$0A1B2C3D4E5F\n"
+ "$BadCafe\n"
+ "-$10\n"
+ "-$aBcDeF";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}