re = /-?\$+?(?:[A-Fa-f]*)?(?:\d)*/
str = '$0
$1
$D
$FFFF
$0A1B2C3D4E5F
$BadCafe
-$10
-$aBcDeF'
# Print the match result
str.match(re) do |match|
puts match.to_s
end