// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-?\$+?(?:[A-Fa-f]*)?(?:\d)*").unwrap();
let string = "$0
$1
$D
$FFFF
$0A1B2C3D4E5F
$BadCafe
-$10
-$aBcDeF";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}