$re = '/-?\$+?(?:[A-Fa-f]*)?(?:\d)*/';
$str = '$0
$1
$D
$FFFF
$0A1B2C3D4E5F
$BadCafe
-$10
-$aBcDeF';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);