import Foundation
let pattern = #"-?\$+?(?:[A-Fa-f]*)?(?:\d)*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$0
$1
$D
$FFFF
$0A1B2C3D4E5F
$BadCafe
-$10
-$aBcDeF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}