import re
regex = re.compile(r"-?\$+?(?:[A-Fa-f]*)?(?:\d)*")
test_str = ("$0\n"
"$1\n"
"$D\n"
"$FFFF\n"
"$0A1B2C3D4E5F\n"
"$BadCafe\n"
"-$10\n"
"-$aBcDeF")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")