const regex = /-?\$+?(?:[A-Fa-f]*)?(?:\d)*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-?\\$+?(?:[A-Fa-f]*)?(?:\\d)*', '')
const str = `\$0
\$1
\$D
\$FFFF
\$0A1B2C3D4E5F
\$BadCafe
-\$10
-\$aBcDeF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}