#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:Copy of )?(?P<showName>.*?)(?: - )?(?P<episode>S\d\dE\d\d)$"
Local $sString = "Bleach S01E02" & @CRLF & _
"Attack on Titan S03E03" & @CRLF & _
"Bleach - S11E12" & @CRLF & _
"Attack on Titan - S19E20" & @CRLF & _
"Copy of Attack on Titan - S10E10" & @CRLF & _
"Copy of Bleach - S01E02"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")