// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:Copy of )?(?P<showName>.*?)(?: - )?(?P<episode>S\d\dE\d\d)$").unwrap();
let string = "Bleach S01E02
Attack on Titan S03E03
Bleach - S11E12
Attack on Titan - S19E20
Copy of Attack on Titan - S10E10
Copy of Bleach - S01E02";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}