re = /^(?:Copy of )?(?P<showName>.*?)(?: - )?(?P<episode>S\d\dE\d\d)$/m
str = 'Bleach S01E02
Attack on Titan S03E03
Bleach - S11E12
Attack on Titan - S19E20
Copy of Attack on Titan - S10E10
Copy of Bleach - S01E02'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end