using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:Copy of )?(?P<showName>.*?)(?: - )?(?P<episode>S\d\dE\d\d)$";
string input = @"Bleach S01E02
Attack on Titan S03E03
Bleach - S11E12
Attack on Titan - S19E20
Copy of Attack on Titan - S10E10
Copy of Bleach - S01E02";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}