import Foundation
let pattern = #"^(?:Copy of )?(?P<showName>.*?)(?: - )?(?P<episode>S\d\dE\d\d)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Bleach S01E02
Attack on Titan S03E03
Bleach - S11E12
Attack on Titan - S19E20
Copy of Attack on Titan - S10E10
Copy of Bleach - S01E02
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)