# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/({#[^}]+}[^{\r\n]+)(?={#|$)/\1{\/}/gm;t' <<< "{#HEXCOLOR}TEXT TEXT TEXT
{#FF00FF}Hello
{#FF00FF}good one here{/}
{#HEXCOLOR}inline text{#FF00FF}Hello{#FF00FF}test{/}
"