import Foundation
let pattern = ##"({#[^}]+}[^{\r\n]+)(?={#|$)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
{#HEXCOLOR}TEXT TEXT TEXT
{#FF00FF}Hello
{#FF00FF}good one here{/}
{#HEXCOLOR}inline text{#FF00FF}Hello{#FF00FF}test{/}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1{/}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)