re = /({#[^}]+}[^{\r\n]+)(?={#|$)/m
str = '{#HEXCOLOR}TEXT TEXT TEXT
{#FF00FF}Hello
{#FF00FF}good one here{/}
{#HEXCOLOR}inline text{#FF00FF}Hello{#FF00FF}test{/}
'
subst = '\\1{/}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result