using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({#[^}]+}[^{\r\n]+)(?={#|$)";
string substitution = @"\1{/}";
string input = @"{#HEXCOLOR}TEXT TEXT TEXT
{#FF00FF}Hello
{#FF00FF}good one here{/}
{#HEXCOLOR}inline text{#FF00FF}Hello{#FF00FF}test{/}
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}