use strict;
my $str = '{#HEXCOLOR}TEXT TEXT TEXT
{#FF00FF}Hello
{#FF00FF}good one here{/}
{#HEXCOLOR}inline text{#FF00FF}Hello{#FF00FF}test{/}
';
my $regex = qr/({#[^}]+}[^{\r\n]+)(?={#|$)/mp;
my $subst = '\\1{/}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";