const regex = /({#[^}]+}[^{\r\n]+)(?={#|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({#[^}]+}[^{\\r\\n]+)(?={#|$)', 'gm')
const str = `{#HEXCOLOR}TEXT TEXT TEXT
{#FF00FF}Hello
{#FF00FF}good one here{/}
{#HEXCOLOR}inline text{#FF00FF}Hello{#FF00FF}test{/}
`;
const subst = `\1{/}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);