import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{#[^\\}]+\\}[^\\{\\r\\n]+)(?=\\{#|$)";
final String string = "{#HEXCOLOR}TEXT TEXT TEXT\n"
+ "{#FF00FF}Hello\n\n"
+ "{#FF00FF}good one here{/}\n\n"
+ "{#HEXCOLOR}inline text{#FF00FF}Hello{#FF00FF}test{/}\n";
final String subst = "\\1{/}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}