#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)({#[^}]+}[^{\r\n]+)(?={#|$)"
Local $sString = "{#HEXCOLOR}TEXT TEXT TEXT" & @CRLF & _
"{#FF00FF}Hello" & @CRLF & _
"" & @CRLF & _
"{#FF00FF}good one here{/}" & @CRLF & _
"" & @CRLF & _
"{#HEXCOLOR}inline text{#FF00FF}Hello{#FF00FF}test{/}" & @CRLF & _
""
Local $sSubst = "\1{/}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)