import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^[^\"]*\"|\\G)[^\"]*?\\K(?<![\" ])[A-Z]";
final String string = ".LabelText(\"ATextWhichHasCapitalLetters\")\n"
+ ".Label(Constants.DefinedLabel)\n"
+ ".Label(\"AnotherTextWhichHasCapitalLetters\")";
final String subst = " $0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}