const regex = /(?:^[^"]*"|\G)[^"]*?\K(?<![" ])[A-Z]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^[^"]*"|\\G)[^"]*?\\K(?<![" ])[A-Z]', 'gm')
const str = `.LabelText("ATextWhichHasCapitalLetters")
.Label(Constants.DefinedLabel)
.Label("AnotherTextWhichHasCapitalLetters")`;
const subst = ` $0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);