re = /(?:^[^"]*"|\G)[^"]*?\K(?<![" ])[A-Z]/m
str = '.LabelText("ATextWhichHasCapitalLetters")
.Label(Constants.DefinedLabel)
.Label("AnotherTextWhichHasCapitalLetters")'
subst = ' $0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result