use strict;
my $str = '.LabelText("ATextWhichHasCapitalLetters")
.Label(Constants.DefinedLabel)
.Label("AnotherTextWhichHasCapitalLetters")';
my $regex = qr/(?:^[^"]*"|\G)[^"]*?\K(?<![" ])[A-Z]/mp;
my $subst = ' $0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";