$re = '/(?:^[^"]*"|\G)[^"]*?\K(?<![" ])[A-Z]/m';
$str = '.LabelText("ATextWhichHasCapitalLetters")
.Label(Constants.DefinedLabel)
.Label("AnotherTextWhichHasCapitalLetters")';
$subst = " $0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;