#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "@shader\(([^)]*)\):(?:\r?\n)((?:[^@]|@(?!shader))*)"
Local $sString = "@shader(vertex):" & @CRLF & _
"...shader data..." & @CRLF & _
"" & @CRLF & _
"@shader(fragment):" & @CRLF & _
"...shader data..."
Local $sSubst = " $0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)