re = /@shader\(([^)]*)\):(?:\r?\n)((?:[^@]|@(?!shader))*)/
str = '@shader(vertex):
...shader data...
@shader(fragment):
...shader data...'
subst = ' $0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result