import re
regex = re.compile(r"@shader\(([^)]*)\):(?:\r?\n)((?:[^@]|@(?!shader))*)")
test_str = ("@shader(vertex):\n"
"...shader data...\n\n"
"@shader(fragment):\n"
"...shader data...")
subst = " $0"
result = regex.sub(subst, test_str)
if result:
print(result)