use strict;
my $str = '@shader(vertex):
...shader data...
@shader(fragment):
...shader data...';
my $regex = qr/@shader\(([^)]*)\):(?:\r?\n)((?:[^@]|@(?!shader))*)/p;
my $subst = ' $0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";