import Foundation
let pattern = #"@shader\(([^)]*)\):(?:\r?\n)((?:[^@]|@(?!shader))*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@shader(vertex):
...shader data...
@shader(fragment):
...shader data...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)