$re = '/@shader\(([^)]*)\):(?:\r?\n)((?:[^@]|@(?!shader))*)/';
$str = '@shader(vertex):
...shader data...
@shader(fragment):
...shader data...';
$subst = " $0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;