using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@shader\(([^)]*)\):(?:\r?\n)((?:[^@]|@(?!shader))*)";
string substitution = @" $0";
string input = @"@shader(vertex):
...shader data...
@shader(fragment):
...shader data...";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}