const regex = /@shader\(([^)]*)\):(?:\r?\n)((?:[^@]|@(?!shader))*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@shader\\(([^)]*)\\):(?:\\r?\\n)((?:[^@]|@(?!shader))*)', 'g')
const str = `@shader(vertex):
...shader data...
@shader(fragment):
...shader data...`;
const subst = ` $0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);