# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S\S)\s+(?!\S\S)//gm;t' <<< "A B C Company
XYZ Inc
S & K Co
A B C D E F G Company"