$re = '/(?<!\S\S)\s+(?!\S\S)/m';
$str = 'A B C Company
XYZ Inc
S & K Co
A B C D E F G Company';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;