use strict;
my $str = 'A B C Company
XYZ Inc
S & K Co
A B C D E F G Company';
my $regex = qr/(?<!\S\S)\s+(?!\S\S)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";