import re
regex = re.compile(r"(?<!\S\S)\s+(?!\S\S)", flags=re.MULTILINE)
test_str = ("A B C Company\n"
"XYZ Inc\n"
"S & K Co\n"
"A B C D E F G Company")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)