const regex = /(?<!\S\S)\s+(?!\S\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S\\S)\\s+(?!\\S\\S)', 'gm')
const str = `A B C Company
XYZ Inc
S & K Co
A B C D E F G Company`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);