using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S\S)\s+(?!\S\S)";
string substitution = @"";
string input = @"A B C Company
XYZ Inc
S & K Co
A B C D E F G Company";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}