#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\S\S)\s+(?!\S\S)"
Local $sString = "A B C Company" & @CRLF & _
"XYZ Inc" & @CRLF & _
"S & K Co" & @CRLF & _
"A B C D E F G Company"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)