using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-val1-([^-]+)(?:-val2-([^-]+)|)(?:-val3-([^-]+)|)-";
string input = @"-val1-test-val2-result-val3-done-
-val1-test-val3-done-
-val1-test-val2-res-";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}