package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-val1-([^-]+)(?:-val2-([^-]+)|)(?:-val3-([^-]+)|)-`)
var str = `-val1-test-val2-result-val3-done-
-val1-test-val3-done-
-val1-test-val2-res-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}