import re
regex = re.compile(r"-val1-([^-]+)(?:-val2-([^-]+)|)(?:-val3-([^-]+)|)-")
test_str = ("-val1-test-val2-result-val3-done-\n"
"-val1-test-val3-done-\n"
"-val1-test-val2-res-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")