$re = '/-val1-([^-]+)(?:-val2-([^-]+)|)(?:-val3-([^-]+)|)-/';
$str = '-val1-test-val2-result-val3-done-
-val1-test-val3-done-
-val1-test-val2-res-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);